• QQ截图20140825143507 这里利用酷Q和小黄鸡的API来做,非常简单 只有20几行代码

     

    因为酷Q插件必须用垃圾易语言写,我从来没有用过易语言,所以用了一个PHP做核心,还能免去渣渣GB2312编码的转换。

     

    error_reporting(0);
    $ch = curl_init();
    curl_setopt($ch,CURLOPT_URL,"http://www.xiaohuangji.com/ajax.php");//调用xiaohuangji.com的API 感谢小黄鸡提供方便的API
    curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
    curl_setopt($ch, CURLOPT_POST,1);
    curl_setopt($ch, CURLOPT_POSTFIELDS,"para=".$_GET['u']);
    $page = curl_exec($ch);
    curl_close($ch);
    $page = iconv( "UTF-8", "gb2312//IGNORE" , $page);//强制转换为GB2312编码方便易语言使用
    echo $page;
    

    将此文件写为robots.php 放到WebServer上 然后酷Q的插件接受消息的函数这样写:

    .版本 2
    .支持库 internet
    
    .子程序 插件的回调函数名, 文本型, 公开
    .参数 a, 文本型
    .参数 b, 文本型
    .参数 c, 文本型
    .参数 d, 文本型
    .参数 e, 文本型
    .局部变量 消息, 文本型
    
    消息 = 到文本 (HTTP读文件 (“http://127.0.0.1/robot.php?u=” + UTF8编码转换 (a)))
    .如果真 (消息 ≠ “”)
        api_message_group_send (c, 消息)
    .如果真结束
    返回 (“”)
    
    .版本 2
    .支持库 iconv
    
    .子程序 UTF8编码转换, 文本型, 公开, 将一个UTF8编码的文本转换为URL编码,返回一个URL编码
    .参数 文本, 文本型, , 需要转换为URL编码的UTF8编码的文本
    .局部变量 URL码, 文本型
    .局部变量 n, 整数型
    .局部变量 UTF8文本, 字节集
    
    UTF8文本 = 编码转换 (到字节集 (文本), #编码_GBK, #编码_UTF_8, )
    .计次循环首 (取字节集长度 (UTF8文本), n)
        URL码 = URL码 + “%” + 取十六进制文本 (UTF8文本 [n])
    .计次循环尾 ()
    返回 (URL码)
    

    了解酷Q的插件开发去官方下载 Example 看看就知道了